« | »
Apr'09
19

vmware

El procedimiento para instalar VMWare 6.5 o VMWare 7 en Ubuntu 9.10 y similares es igual solo que cambiando los nombres de los ficheros y versiones.

Es curioso como en ocasiones hasta las cosas más sencillas se resisten, simplemente porque es la primera vez que has haces, pues bien, ésta es una de esas cosas que ha osado resistírseme, pero al final lo he conseguido.

Realmente la versión de VMware que se me ha resistido ha sido la 6.0.4, que es la que tenía yo.

  • Si no tenemos VMware Workstation 6.5, nos dirigimos a la página oficial de VMware, nos registramos y accedemos al área de descarga de la versión Workstation.
  • Nos descargamos la que corresponda a nuestra arquitectura (32bit o 64bit), y que tenga la extensión .bundle
  • Abrimos el terminal, nos dirigimos a la carpeta en la cual nos hemos descargado el .bundle
  • Instalamos Build Essentials y Linux Headers con el comando:

~$ sudo apt-get install build-essential linux-headers-`uname -r`

  • Instalamos xinetd con el comando:

~$ sudo apt-get install xinetd

  • ejecutamos en terminal:

~$ sudo sh VMware-Workstation-6.5.1-126130.i386.bundle

  • Ahora se ejecutará un instalador gráfico, con el que sólo hará falta seguir los pasos que se van indicando.

Actualización:

Si la sentencia

~$ sudo apt-get install build-essential linux-headers-‘uname -r’

No te funciona, prueba con:

~$ sudo apt-get install linux-headers-2.6.28-13-generic

Además es posible que no te reconozca ciertas teclas, como las flechas, el Alt Gr o la tecla de windows, para solucionarlo, tal y como nos cuentan en Keopx, ejecutar en consola:

~$ sudo vim /home/usuario/.vmware/config

y escribe en el fichero:

xkeymap.keycode.108 = 0x138 # Alt_R
xkeymap.keycode.106 = 0x135 # KP_Divide
xkeymap.keycode.104 = 0x11c # KP_Enter
xkeymap.keycode.111 = 0x148 # Up
xkeymap.keycode.116 = 0x150 # Down
xkeymap.keycode.113 = 0x14b # Left
xkeymap.keycode.114 = 0x14d # Right
xkeymap.keycode.105 = 0x11d # Control_R
xkeymap.keycode.118 = 0x152 # Insert
xkeymap.keycode.119 = 0x153 # Delete
xkeymap.keycode.110 = 0x147 # Home
xkeymap.keycode.115 = 0x14f # End
xkeymap.keycode.112 = 0x149 # Prior
xkeymap.keycode.117 = 0x151 # Next
xkeymap.keycode.78 = 0x46 # Scroll_Lock
xkeymap.keycode.127 = 0x100 # Pause
xkeymap.keycode.133 = 0x15b # Meta_L
xkeymap.keycode.134 = 0x15c # Meta_R
xkeymap.keycode.135 = 0x15d # Menu

Si disfrutaste del artículo, puedes suscríbete a nuestro feed RSS
Categoría(s): Linux
Si te gustó este artículo o bien deseas seguirnos diariamente tal vez desees suscribirte a nuestro canal RSS vía email o bien vía lector de feeds. Recuerda que si usas tu email debes verificar la activación de tu suscripción (si tarda mucho revisa en tu carpeta spam).
Puedes dejar un comentario, o hacer un Trackback desde tu sitio.

25 comentarios en “VMWare 6.5 en Ubuntu 9.04 y 9.10”

  1. africa says:

    muchas gracias

  2. Felipe says:

    Buenas, gracias por este tutorial llevaba volviendome loco no se ni cuanto tiempo! te comento tengo kubuntu 9.04, he hecho lo que pusiste y me dio un error en:
    ~$ sudo apt-get install build-essential linux-headers-’uname -r’
    pq dice no reconocer la opcion r
    pero seguí pa’alante conseguí ver la parte gráfica pero ahora me dice que no encuentra los kernel headers 2.6.27-11 generic y el problema es que yo he revisado y tengo los 2.6.28 y no me aparecen la versión que pide, no tendrás idea de como apañarlo? un saludo y muchas gracias

    • Alejandro says:

      A decir verdad me pasó lo mismo en la máquina de un compañero, y cuando me dio el error (en el que pone que no acepta el -r), directamente lo que hice fue quitar el -r y todo fue a pedir de boca, no se si te servirá a ti también ;)

  3. osc.2001 says:

    al ejecutar tu comando
    ~$ sudo sh VMware-Workstation-6.5.1-126130.i386.bundle

    este me responde y no he podido instalar
    sh: Can’t open VMware-Workstation-6.5.1-126130.i386.bundle

    • Alejandro says:

      es posible que hayan actualizado el paquete *.bundle y la versión que te hayas bajado no se llame exactamente igual, ¿te has asegurado que se llama igual el que te has descargado?

  4. osc.2001 says:

    busque y busque y era una tonteria y a todos nos puede pasar resulta que desde termin debo ir hasta hasta el lugar donde se ha guardado el archivo descargado. En mi caso, se encuentra en el escritorio de la cuenta de usuario con la que estoy trabajando (que precisamente se llama usuario). Por consiguiente, escribi la siguiente orden:

    cd /home/usuario/Escritorio/

    y alli si pude instalar

  5. Dospuntos says:

    Hola.
    Segui las recomendaciones, y la instalacion se completo sin inconveniente pero algo muy raro sucede, cuando inicio VMware Workstation muestra el recuadro en la barra inferior “Starting VMware”, pero nucna inicia el programa.

    A alguno de ustedes le ha sucedido? En versiones anteriores de Ubuntu nunca habia tenido inconveniente.

    Les agradezco si alguno de ustedes me puede ayudar.

    • Alejandro says:

      Hmn que cosa más rara, no me ha pasado en ninguno de los pc’s en los que lo he instalado, y no han sido pocos… no se me ocurre porqué puede ser, y supongo que ya habrás reiniciado el pc así como haber cerrado todos los procesos manualmente no?

  6. Guido says:

    Hola

    Me adiero al problema de “Dospuntos”. Tengo instalado el Kubuntu 9.04 para amd64…

    saludos y gracias

  7. agustin says:

    tenia el problema de la -r y se solucionó haciendo todo lo anterior
    y ademas igresando este comando:
    sudo apt-get install linux-headers-2.6.28-13-generic

  8. santi says:

    muy bueno, todo me salio a la perfeccion siguiendo estas instrucciones, gracias por el aporte…

  9. berny says:

    Mil gracias :P, saludos

  10. Mittaus says:

    El comando :

    ~$ sudo apt-get install build-essential linux-headers-’uname -r’

    es con las comillas inclinadas hacia atrás.

    ~$ sudo apt-get install build-essential linux-headers-`uname -r`

  11. Alejandro says:

    @Miattus es posible que sea por eso por lo que a veces no reconocía el uname -r gracias or la corrección

  12. pedro lopez says:

    hola a mi se me queda pegado en la parte de instalacion….copia las filas de VMware player 2.5.3 se queda pegado………..
    dice “configuring”

    alguna solucion, instale ubuntu 9.10, con el 9.04 no tenia problemas

  13. victor says:

    Muchas gracias, soy nuevo en linux y si que me estava llevando un lio con esto, muchas gracias

  14. kook says:

    hola
    hice los pasos al pie de la letra y me funciona de maravilla
    pero cuando la corro me dice que necesita instalar un up date a lo que yo le doy que si pero me dice (unable to build kernel module) y has ahí llego la alegría y pues si alguien me puede colaborar le agradecería. tengo ubuntu 9.10 y el kernel en .15

  15. Dr.Fr3ddyL0ck says:

    Buenas, gracias por las soluciones de arriba, yo ya instale vmware workstation 6.5.2 en mi ubuntu 9.10 y tengo el mismo problema que kook, si me podrias explicar como solucionar ese problema estaria muy agradecido, soy nuevo en esto de linux… salu2-

  16. Alejandro says:

    prueba a ejecutar

    sudo apt-get install build-essential linux-headers-’uname -r’

  17. Bypper says:

    Me temo que no es tan sencillo.

    Vmware WS 6.5 + Ubuntu 9.10 no rula. Tiene problemas a la hora de compilar los modulos.

    La versión 7 requiere de un kernel con PAE, si no es el caso, olvidate de esa version.

  18. Bypper says:

    Si pero porque tu tendras el flag PAE en el procesador.

    para saberlo:

    grep flags /proc/cpuinfo | grep pae

    te dará salida, si no sale nada, obtendrás un mensaje de error al arrancar cualquier maquina virtual.

  19. Wilmer says:

    Alguno tiene idea de lo que me sucede con esta maquina, les comento instale VMWare 7 sobre ubuntu 10.10 y pues ya instalo pero al momento de querer ingresar a la interfaz grafica de VMware me dice que hay problemas con el Kernel y que lo actualizara, comeinza a bajar algo para el monitor dice no disponible y hasta ahi llego.
    este es el error , si alguno me puede ayudar a corregirlo porfa, mientras trabajo con virtualbox, pero necesito vmware gracias
    Unable to build kernel module.

Deje su comentario

XHTML: Puedes utilizar algunos códigos HTML: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>

« | »